Published on December 04, 2018 (Updated on December 04, 2018)

SG Delay Run [Minigame]

Installation Guides

I can’t use it in 1.7.0. Please make a note of this.
Same can’t use in 1.7.0
Can you put 1.9 only in the title I’m on iOS and I can’t play and I have no idea if I can use these things